新闻快讯
< >

加密Bug影响苹果等大型厂商蓝牙、操作系统驱动程序!

E安全7月25日讯 E安全7月25日讯 来自以色列理工学院的两位科学家 Lior Neumann 与 Eli Biham 发现,一项加密 Bug (编号CVE-2018-5383)已被证实影响到多种蓝牙及操作系统驱动程序,影响苹果、博通、英特尔、高通等多家硬件供应商的相关产品。

 加密Bug已证实影响到多种蓝牙与操作系统驱动程序-E安全

漏洞原因

造成此项 Bug 的原因,在于支持蓝牙功能的设备无法充分验证“安全”蓝牙连接期间所使用的加密参数。更准确地说,配对设备无法充分验证在 Diffie-Hellman 密钥交换期间用于生成公钥的椭圆曲线参数。

这将导致弱配对问题,并可能允许远程攻击者获取设备所使用的加密密钥并恢复在“安全”蓝牙连接中配对的两台设备间发送的往来数据。

蓝牙与蓝牙LE皆会受到影响

蓝牙标准中的“安全简单配对”过程与蓝牙LE(低功耗蓝牙)中的“安全连接”配对过程皆会受到影响。

CERT/CC 在2018年7月23日发布了一份安全通报,其中包含以下与此项漏洞相关的说明:

蓝牙利用基于椭圆曲线 Diffie-Hellman(简称ECDH)密钥交换的设备配对机制实现设备之间的加密通信。ECDH 密钥由私钥及公钥组成,且双方交换公钥以共享配对密钥。设备还必须接受所使用的椭圆曲线参数。此前关于“曲线无效化攻击”证明,ECDH 参数在用于计算共享密钥之前并不总会经过验证——即可能并未验证所有共享密钥计算之前存在的参数,这可能减少攻击者获取受攻击设备私钥时需要处理的工作量。

在某些实现方案中,椭圆曲线参数并未全部由加密算法进行验证,这将允许处于同一无线范围内的远程攻击者注入无效公钥以高概率确定会话密钥。此后,攻击者将能够以被动方式拦截并解密所有设备间往来消息,及/或伪造与注入恶意消息。

 加密Bug已证实影响到多种蓝牙与操作系统驱动程序-E安全

多家大型供应商受到影响

苹果、博通、英特尔以及高通等公司已经确认其蓝牙与操作系统驱动程序受到影响。

  • 苹果与博通双方针对该项漏洞部署了修复程序;

  • 英特尔与高通方面尚未做出补救性举措;

CERT/CC 专家们还无法确定 Android、谷歌设备或者其它 Linux 内核类方案是否受到影响。

微软不受影响

微软公司表示,其设备不会受到影响。

蓝牙特别兴趣小组(简称 SIG)作为蓝牙标准的开发监督机构,已经就此项安全漏洞发布一份声明:

要成功实施攻击,攻击方需要确保攻击设备处于通过配对程序连接的两台易受攻击蓝牙设备的无线范围之内。攻击设备需要阻止每一次传输、向发送设备发送确认,而后在短时间窗口内将恶意数据包注入接收设备的方式拦截公钥交换过程。如果配对双方中只有一台设备存在漏洞,则攻击无法成功。

该组织表示,目前其已经更新了蓝牙官方标准,要求所有配对设备必须对加密蓝牙连接中基于密钥的所有参数进行验证。研究人员与蓝牙 SIG 指出,他们还没有发现任何可能利用此项安全漏洞的实际攻击活动。

补丁发布方式

此项针对 CVE-2018-5358 漏洞的更新将以操作系统更新/驱动程序更新(面向台式机、笔记本电脑以及智能手机)或固件更新(面向物联网/智能设备)的方式发布。

E安全注:本文系E安全独家编译报道,转载请联系授权,并保留出处与链接,不得删减内容。联系方式:① 微信号zhu-geliang ②邮箱eapp@easyaq.com
@E安全,最专业的前沿网络安全媒体和产业服务平台,每日提供优质全球网络安全资讯与深度思考,欢迎关注微信公众号「E安全」(EAQapp),或登E安全门户网站www.easyaq.com , 查看更多精彩内容。