新闻快讯
< >

Splunk修复数个Enterprise与Light产品安全漏洞

最近,Splunk修复了许多存在于其Enterprise与Light系列产品中的安全漏洞,其中部分漏洞安全评级为“高危”。

Splunk Enterprise为其他组织提供数据搜索、分析及可视化功能,这些数据采集自网站、应用软件、传感器(注:通常指安全设备)及其他设备。Splunk Light小型IT网的日志检索与日志分析自动化、服务器与互联网监控的解决方案。

 Splunk修复数个Enterprise与Light产品安全漏洞-E安全

这些产品中最危险的漏洞——通用漏洞评分系统(CVSS)评分为8.1(高危)——是Splunk网页界面中的一个跨站点脚本 (XSS) 漏洞 CVE-2018-7427

 另一高危漏洞,让攻击者通过向处理索引、搜索、转发进程的系统进程Splunkd发送特制的HTTP请求,发起拒绝服务攻击 (DoS)。该漏洞编号为CVE-2018-7429

 CVE-2018-7432是类似的拒绝服务漏洞,利用该漏洞的方式也是向Splunkd发送恶意HTTP请求,但厂商仅将其评级为“中危”

 最后一个漏洞CVE-2018-7431,危险级别也为“中危”,属于路径遍历漏洞,可允许通过身份验证的攻击者在Splunk Django应用程序中下载任意文件

 其中两个漏洞感染SplunkEnterprise系列6.5.3前版本6.5.x,6.4.7前版本6.4.x,6.3.10前版本6.3.x,6.2.14前版本6.2.x,6.1.13前版本6.1.x,6.0.14前版本6.0.x以及6.6.0前版本Splunk Light;漏洞CVE-2018-7432影响除6.1.x 与 6.0.x版本外的上述相同的版本,其他感染版本与以上两个漏洞一致;而漏洞CVE-2018-7429感染Enterprise 系列6.4.8前版本6.4.x,6.3.11前版本6.3.x,6.2.14前版本6.2.x以及6.5.0前版本Light。

 Splunk 表示,目前尚无证据表明这些漏洞已遭黑客恶意利用。

 Splunk在一次公告中表示“为了缓解这些问题,Splunk建议您升级到最新版本,并应用尽可能多的,与您环境相关的Securing Splunk文件中的加固标准(Hardening Standards)。SplunkEnterprise与Splunk Light的发布是累积的(注:不单独发布修复补丁)。也就是说,未来的版本更新中将会修复这些漏洞,增加新功能以及其他错误的修正”。