新闻快讯
< >

影响Icecast流媒体服务器的漏洞可停播网络广播电台

黑客可利用影响Icecast流媒体服务器的漏洞停播网络广播电台。

Icecast流媒体服务器受编号为“CVE-2018-18820”的漏洞影响,黑客可利用该漏洞停播网络广播电台。Icecast由Xiph.org基金会维护,可支持视频和音频数据。Icecast是在GNU通用公共许可协议(GNU GPL)版本2下分发的,可用于创建网络广播电台、私人点唱机以及介于两者之间的其他产品。 

该漏洞是Semmle安全研究团队通过LGTM发现的,LGTM软件可通过分析检查出有漏洞的代码。  

该安全研究团队在公告中表示,“我们发现,由Xiph.org基金会维护的开源流媒体服务器Icecast中存在漏洞。” 

 “攻击者可制作HTTP标头,覆盖服务器的堆栈内容,从而远程执行代码。由于Icecast常用于支持网络广播电台,因此恶意攻击者可借此使电台停播。” 

配置URL认证的Icecast服务器的2.4.0至2.4.3版本均受该漏洞影响。 

专家开发并利用了一个概念验证,其可在服务器中造成一个触发拒绝服务的分段错误。专家指出,黑客若继续开发,其将获得受感染系统的全面远程代码执行权。 

影响Icecast流媒体服务器的漏洞可停播网络广播电台-E安全

Icecast

很快,Xiph专家们迅速而且巧妙地修复了该漏洞。 

该公告还表示,“Xiph员工迅速修复了该漏洞。修复方法很简单,只需检查snprintf的返回值,若其导致post_offset的指向超出缓冲区,它便会记录一个错误并退出循环。” 

用户应尽快将安装升级版本2.4.4。 

有关该漏洞的技术细节,可前往Semmle安全研究团队尼克·罗尔夫(Nick Rolfe)发布的帖子中查看。


E安全注:本文系E安全独家编译报道,转载请联系授权,并保留出处与链接,不得删减内容。联系方式:① 微信号j871798128②邮箱eapp@easyaq.com

@E安全,最专业的前沿网络安全媒体和产业服务平台,每日提供优质全球网络安全资讯与深度思考,欢迎关注微信公众号「E安全」(EAQapp),或登E安全门户网站户网站户网站www.easyaq.com , 查 , 查 , 查看更多精彩内容。